SSL Certificate Provider
 

Product successfully added to your shopping cart

Total products (tax incl.)
Total shipping (tax incl.) To be determined
Total (tax incl.)
Continue shopping Proceed to checkout

GTPay Payment Module

Our GTPay Payment Module integrates your Prestashop store with GTPay payment gateway.

price $50.00


Compatibility Compatibility
Prestashop 1.4 Prestashop 1.5 Prestashop 1.6 Prestashop 1.7
Translations Available Translations
English

Our GTPay Payment Module integrates your Prestashop store with GTPay payment gateway.

 

GTPay is a secure internet payment gateway developed to facilitate payments online using debit Cards issued by banks on the Interswitch Network. GTPay plugs in seamlessly with the existing websites of customers and acts as a bridge between the customer's website and financial institutions (Banks).


The module collects the customer and cart information and forwards the customer to the GTPay payment solution to finalize payment.  The module will create an Order within Prestashop after the payment is successful.

 

The module is PCI compliant.

PreRequisites

You must have a GTPay merchant account In order to use this module.  Visit GTPay for additional information.

Certified for Prestashop v1.4, v1.5, v1.6 and v1.7

PS 1.4 Compatible:Yes
PS 1.5 Compatible:Yes
PS 1.6 Compatible:Yes
PS 1.7 Compatible:Yes
ThirtyBees Compatible:No
ApplePay:Not Supported
  • v3.0.0: Add support for Prestashop v1.7
  • v2.0.0:
    • Module configuration refactored to use PS v1.6 bootstrap
    • Removed support for PS v1.4 and PS v1.5.  Use module v1.7 for older PS versions
  • v1.7: implemented the Requery transaction to avoid man in the middle attacks
  • v1.6: updated the hash algorithm based on recent gateway changes
  • v1.5: added gtpay_gway_name to the gateway transaction.  The value sent to the gateway is always empty
  • v1.4:
    • The module updated to support the required Hash Key
    • The module now creates a Transaction Id and sends it to GTPay, instead of relying on GTPay to create one
  • v1.3: Initial Public Release

Our GTPay Payment Module includes support for PS v1.4, v1.5, v1.6 and v1.7. After your purchase is complete, please make sure you download and install the correct module version for your store

Prestashop v1.4: Use gtpay_v1.7.zip

Prestashop v1.5: Use gtpay_v1.7.zip

Prestashop v1.6: Use gtpay_v2.0.0.zip

Prestashop v1.7: Use gtpay_v3.0.0.zip