Product successfully added to your shopping cart

Total products (tax incl.)
Total shipping (tax incl.) To be determined
Total (tax incl.)
Continue shopping Proceed to checkout

Swift Mailer Upgrade (Better Support for SSL/TLS)

A modification to Prestashop that upgrades the Swift Mailer library to the latest software version.

price $24.95


Compatibility Compatibility
Prestashop 1.4 Prestashop 1.5 Prestashop 1.6
Translations Available Translations
English

Prestashop v1.6.1.5 has included an updated version of the Swift Mailer library.  While it is not the latest version of SwiftMailer, it should address the lack of STARTTLS and allow you to connect to modern gateways.

Therefore I will not be maintaining this modification going forward.  I will however keep my modification for those on previous versions of Prestashop

For those of you on PS v1.5 and v1.6, there is now a free module created by contributor Michael Dekker that you can use as well.

https://www.prestash...er-version-541/

The version of SwiftMailer that is included with Prestashop was released in 2007 and is quite old and unsupported.  One of the issues with this version is that it does not properly work with modern mail systems that require a STARTTLS command.

 

If you are trying to use a SMTP server and you are receiving an error similar to below, then it means you are having an issue connecting to the SMTP server due to lack of STARTTLS.

The SMTP connection failed to start [tls://smtp.live.com:587]: fsockopen returned Error Number 0 and Error String
The SMTP connection failed to start [tls://smtp.gmail.com:587]: fsockopen returned Error Number 0 and Error String

 

This modification does two things.

  1. It includes SwiftMailer v5.4.1 that you will upload to your website using FTP
  2. It includes an updated Prestashop Mail class that has been refactored to work with the above SwiftMailer version

 

This modification will replace your existing Mail class file.  Due to the nature of this issue, this is not a module and is not created as an override.

 

This modification will replace the SwiftMailer library packaged with Prestashop, with SwiftMailer v5.4.1 released on June 6 2015.  I do not provide support for SwiftMailer, or other errors you may receive after installing this modification.  For more information about SwiftMailer, you can visit their website http://swiftmailer.org/

 

You will need to confirm that you are using PHP version 5.3 or higher.  SwiftMailer no longer supports PHP 5.2

PS 1.4 Compatible:Yes
PS 1.5 Compatible:Yes
PS 1.6 Compatible:Yes
  • v1.14: Now also supports PS v1.6.1.4.  SwiftMailer library upgraded to v5.4.1 (formerly v5.3.1)
  • v1.13: Now also supports PS v1.6.1.3
  • v1.12: Now also supports PS v1.6.1.2 and PS v1.5.3.1
  • v1.11: Now also supports PS v1.6.1.1
  • v1.10: Now also supports PS v1.6.1.0
  • v1.9: Now also supports PS v1.6.0.11, v1.6.0.12, v1.6.0.13 and v1.6.0.14.  SwiftMailer library upgraded to v5.3.1 (formerly v5.1.0)
  • v1.8: Now also supports PS v1.6.0.9
  • v1.7: Now also supports PS v1.6.0.6 and v1.6.0.8
  • v1.6: Now also supports PS v1.5.6.2
  • v1.5: Now also supports PS v1.6.0.5
  • v1.4: Now also Supports v1.5.6
  • v1.3: Now also Supports v1.5.5
  • v1.2: Now also Supports v1.4.8.2, v1.4.8.3, v1.4.9, v1.4.10 and v1.4.11
  • v1.1: Now also Supports v1.4.7, v1.4.7.2 and v1.4.7.3
  • v1.0: Initial public release

Once you purchase the modification, you will receive an email containing a download link.  Download the modification package to your computer

 

Next you will need extract the package using a zip utility, such as winzip.  Once extracted, open the readme.pdf file and continue following the instructions.

This modification currently supports the following Prestashop versions

  • v1.4.7, v1.4.7.2, v1.4.7.3
  • v1.4.8.2, v1.4.8.3
  • v1.4.9
  • v1.4.10
  • v1.4.11
  • v1.5.3.1
  • v1.5.4.1
  • v1.5.5
  • v1.5.6
  • v1.6.0.5, v1.6.0.6, v1.6.0.8, v1.6.0.9, v1.6.0.11, v1.6.0.12, v1.6.0.13 and v1.6.0.14
  • v1.6.1.0, v1.6.1.1, v1.6.1.2, v1.6.1.3, v1.6.1.4

 

If your version is not listed here, just contact me before you purchase, and confirm that I will include your version.

 

Note: SwiftMailer no longer supports PHP v5.2.  Ensure you are using PHP V5.3 or greater