SSL Certificate Provider
 

Product successfully added to your shopping cart

Total products (tax incl.)
Total shipping (tax incl.) To be determined
Total (tax incl.)
Continue shopping Proceed to checkout

Mail Alerts PDF Invoice Attachment

Modification that attaches the PDF invoice to the new order email notification sent by the Mail Alerts module.

price $19.95


Compatibility Compatibility
Prestashop 1.5 Prestashop 1.6 Prestashop 1.7
Translations Available Translations
English

The standard Mail Alerts module sends an email message that notifies interested parties that a new order has been received.  However this email message does not include the PDF invoice.


This modification creates the PDF invoice and attaches it to the email notification that is sent.  This is not a module that you install, but rather a modification that will require you to manually copy files to your server using FTP or your web hosting control panel.  The invoice will only be included for 'valid' order statuses.  You will need to ensure your order status for a new order includes creation of an invoice.

 

The modification has 2 installation steps summarized below.  Refer to the installation procedures for additional information

1) First you must identify your Prestashop version, and install an override class file.

2) Second you must identify your Mailalerts module version, and replace one of your existing files with the new one provided. 

Overrides:Yes
PS 1.5 Compatible:Yes
PS 1.6 Compatible:Yes
PS 1.7 Compatible:Yes
  • v1.18: add support for PS v1.6.1.23
  • v1.17: add support for PS v1.7.3.4
  • v1.16: add support for PS v1.7.3.0 and v1.7.4.0 and Mail Alerts v2.1.0
  • v1.15: add support for PS v1.6.1.13, PS v1.6.1.14, PS v1.7.1.1 and Mailalerts module v2.0.1
  • v1.14: add support for PS v1.6.1.11, PS v1.6.1.12 and Mailalerts module v3.6.1
  • v1.13: add support for PS v1.6.0.12
  • v1.12: add support for PS v1.6.0.9
  • v1.11: add support for PS v1.6.1.5.  Also fixed missing folder for v1.6.1.4
  • v1.10: add support for PS v1.6.1.3 and v1.6.1.4
  • v1.9: add support for PS v1.6.1.0, PS v1.6.1.1, PS v1.6.1.2 and Mailalerts module v3.6
  • v1.8: add support for PS v1.6.0.6, PS v1.6.0.8 and Mailalerts module v3.3
  • v1.7: add support for PS v1.6.0.5 and Mailalerts v3.2.5
  • v1.6: add support for PS v1.5.2
  • v1.5: add support for PS v1.5.6.2 (Mail Alerts module version 2.8 and 3.2)
  • v1.4: Adds support for PS v1.5.6.1 (Mail Alerts module version 2.8 and 2.9)
  • v1.3: Adds support for PS v1.5.6
  • v1.2: Adds support for PS v1.5.5
  • v1.1: Includes customization for PS v1.5.4.1 and v1.5.3.1

Once you purchase the modification, you will receive an email containing a download link.  Download the modification package to your computer

 

Next you will need extract the package using a zip utility, such as winzip.  Once extracted, open the install.txt file and following the instructions.

This modification currently supports the following Prestashop versions

  • v1.7.4.0
  • v1.7.3.4
  • v1.7.3.0
  • v1.7.1.1
  • v1.6.1.0, v1.6.1.1, v1.6.1.2, v1.6.1.3, v1.6.1.4, v1.6.1.5, v1.6.1.11, v1.6.1.12, v1.6.1.13, v1.6.1.14, v1.6.1.23
  • v1.6.0.5, v1.6.0.6, v1.6.0.8, v1.6.0.9, v1.6.0.12
  • v1.5.6.2
  • v1.5.6.1
  • v1.5.6
  • v1.5.5
  • v1.5.4.1
  • v1.5.3.1
  • v1.5.2 

 

This modification currently supports the following Mailalert module versions

  • v2.0.1 (PS v1.7)
  • v2.1.0 (PS v1.7)
  • v2.4
  • v2.5
  • v2.8
  • v2.9
  • v3.2
  • v3.2.5
  • v3.3
  • v3.6
  • v3.6.1
  • v3.7.0

 

If your version is not listed here, just contact me before you purchase, and confirm that I will include your version.